Issues converting Visual Studio 2005 Projects to Visual Studio 2008.

 
There were a few Web Application Projects that failed to convert without any reason.
The Upgrade file was just like this:   
 
<?xml-stylesheet type=’text/xsl’ href=’_UpgradeReport_Files/UpgradeReport.xslt’?>
<UpgradeLog> <Event ErrorLevel=3 Project=TSA.Testing.AssemblyTest2 Source=mainTSATestingTSA.Testing.AssemblyTestTSA.Testing.AssemblyTest2.csproj Description=Not Converted>
</Event></UpgradeLog>

One of the project on my local machine had the following line
  <Import Project=”$(MSBuildExtensionsPath)MicrosoftVisualStudiov8.0WebApplicationsMicrosoft.WebApplication.targets” Condition=”” />

When I removed Condition=””,  it was successfully converted to 2008.

For other projects we were not able to find the reason of failure, and we created blank Web Application Projects and import existing files, that belonged to original projects.

  Another issue was that projects with XSD files had generated files modified and corrupted. I found that this issue happens on my machine only, but not  on other machines. I’ve noticed that Xsd files have XsdCodeGen Custom tool specified in the project.My XsdCodeGen has been install a long time ago from  code samples of Code Generation in the .NET Framework Using XML Schema(http://msdn.microsoft.com/en-us/library/aa302301.aspx).Conversion Wizard invoked the XsdCodeGen and tried to re-generate c# code , but failed(It seems that XsdCodeGen doesn’t work with includes) .

I’ve uninstalled the XsdCodeGen from my machine and generated files were left unmodified.

If Web Reference URL in the Setings(and APP.Config) is not correct(e.g. out of date), Conversion Wizard tries to re-generate Web Service client. It doesnt report an error, but subsequent comilation failed:

Error 1 Custom tool error: Unable to import WebService/Schema. The object ‘Settings’ already contains a property … not of type WebServiceUrl. in Reference.map 

 It is important to ensure, that Web Reference URL is correct. I beleive that Conversion Wizard should NOT re-generate clients, or at least it should be optional. 

Setup Project Issues

After re-creating of a new VS 2008 WAP project, My setup project failed with the error:
ERROR: Unable to build project output group ‘Content Files from WebApplicationName
Despite the APPLIES TO section(referring to VS2002-2003), it is still valid for VS 2008, and Microsoft didn’t add any output to point, which file are missing, As recommended by Scott Hanselman, you still have to turn on ‘Show All Files‘ and open EVERY folder until you find one with the Yellow Yield Icon.
There was a thread http://channel9.msdn.com/forums/TechOff/259614-VS2008-Web-Setup-Project-Build-Fails/ that looked relevant to my error, but actually wasn’t applicable to my problem.
Also my setup projects were broken, because they refer to old WAP projects. I had to remove old “Project outputs” and re-add new ones.